DoubleConverter Class |
The DoubleConverter class converts types to and from the double datatype.
Inheritance Hierarchy
Namespace: Tekla.Structures.Datatype
Assembly: Tekla.Structures.Datatype (in Tekla.Structures.Datatype.dll) Version: 2023.0.3
Syntax
The DoubleConverter type exposes the following members.
Constructors
Name | Description | |
---|---|---|
DoubleConverter | Initializes a new instance of the DoubleConverter class |
Methods
Name | Description | |
---|---|---|
CanConvertFrom |
Checks whether the conversion can be made from the source type to the double datatype.
(Overrides TypeConverterCanConvertFrom(ITypeDescriptorContext, Type).) | |
CanConvertTo |
Checks whether the conversion can be made from the double datatype to the destination type.
(Overrides TypeConverterCanConvertTo(ITypeDescriptorContext, Type).) | |
ConvertFrom |
Converts an object from the given culture to the Tekla.Structures.Datatype.Double type.
(Overrides TypeConverterConvertFrom(ITypeDescriptorContext, CultureInfo, Object).) | |
ConvertTo |
Converts an object from the double datatype to the given destination type.
(Overrides TypeConverterConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type).) |
See Also