DistanceList Structure

A list of Distance instances.

Namespace:  Tekla.Structures.Datatype
Assembly:  Tekla.Structures.Datatype (in Tekla.Structures.Datatype.dll) Version: 2023.0.3
Syntax
[SerializableAttribute]
[TypeConverterAttribute(typeof(DistanceListConverter))]
public struct DistanceList : IXmlSerializable, 
	IList<Distance>, ICollection<Distance>, IEnumerable<Distance>, 
	IEnumerable, IFormattable

The DistanceList type exposes the following members.

Constructors
  NameDescription
Public methodCode exampleDistanceList
Initializes a new instance of the structure.
Top
Properties
  NameDescription
Public propertyCode exampleCount
Gets the number of items in the list.
Public propertyIsReadOnly
Gets a boolean value indicating whether the collection is read-only.
Public propertyCode exampleItem
Gets or sets the item at the specified index.
Top
Methods
  NameDescription
Public methodCode exampleAdd
Adds the specified item at the end of the list.
Public methodCode exampleClear
Clears the list.
Public methodCode exampleContains
Determines whether the specified item is in the list.
Public methodCode exampleCopyTo
Copies the contents of the list to an array.
Public methodCode exampleGetEnumerator
Gets an enumerator for enumeraring through the list.
Public methodCode exampleIndexOf
Returns the index of the first matching item in the list.
Public methodCode exampleInsert
Inserts an item at the specified position.
Public methodStatic memberCode exampleParse(String)
Parses a distance list from a string representation.
Public methodStatic memberCode exampleParse(String, IFormatProvider)
Parses a distance list from a string representation.
Public methodStatic memberCode exampleParse(String, IFormatProvider, DistanceUnitType)
Parses a distance list from a string representation.
Public methodCode exampleRemove
Removes the specified item.
Public methodCode exampleRemoveAt
Removes an item at the specified position.
Public methodCode exampleToArray
Copies the contents of the list into a new array.
Public methodCode exampleToString
Returns the string representation of the distance list.
(Overrides ValueTypeToString.)
Public methodCode exampleToString(IFormatProvider)
Returns the string representation of the distance list.
Public methodCode exampleToString(String, IFormatProvider)
Returns the string representation of the distance list.
Public methodCode exampleToString(String, IFormatProvider, DistanceUnitType)
Returns the string representation of the distance list.
Top
Remarks
DistanceLists are used to store related Distance instances in an enumerable, formattable list.
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next