DistanceListConverter Class |
The DistanceListConverter class converts types to and from the distance list type.
Inheritance Hierarchy
Namespace: Tekla.Structures.Datatype
Assembly: Tekla.Structures.Datatype (in Tekla.Structures.Datatype.dll) Version: 2023.0.3
Syntax
The DistanceListConverter type exposes the following members.
Constructors
Name | Description | |
---|---|---|
DistanceListConverter | Initializes a new instance of the DistanceListConverter class |
Methods
Name | Description | |
---|---|---|
CanConvertFrom |
Checks whether the conversion can be made from the source type to the distance list type.
(Overrides TypeConverterCanConvertFrom(ITypeDescriptorContext, Type).) | |
CanConvertTo |
Checks whether the conversion can be made from the distance list type to the destination type.
(Overrides TypeConverterCanConvertTo(ITypeDescriptorContext, Type).) | |
ConvertFrom |
Converts an object from the given culture to the distance list type.
(Overrides TypeConverterConvertFrom(ITypeDescriptorContext, CultureInfo, Object).) | |
ConvertTo |
Converts an object from the distance list type to the given destination type.
(Overrides TypeConverterConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type).) |
See Also