Distance Constructor (Double, DistanceUnitType)

Initializes a new instance of the structure.

Namespace:  Tekla.Structures.Datatype
Assembly:  Tekla.Structures.Datatype (in Tekla.Structures.Datatype.dll) Version: 2023.0.3
Syntax
public Distance(
	double distance,
	DistanceUnitType unitType
)

Parameters

distance
Type: SystemDouble
The distance in the specified units.
unitType
Type: Tekla.Structures.DatatypeDistanceUnitType
The distance unit type.
Exceptions
ExceptionCondition
ArgumentExceptionThrown if an invalid unit type is specified.
Examples
This example shows how to construct a new Distance instance with a specific unit type.
using Tekla.Structures.Datatype;

public class Example
{
       public void Example1()
       {
           Distance distance = new Distance(2, Distance.UnitType.Inch);
       }
}
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next