OperationDisplayReport Method |
Opens and displays a report with the given name.
If a path is not given in the filename, the file is searched from the folder defined with the advanced option XS_REPORT_OUTPUT_DIRECTORY.
See Tekla Structures Help for more information about reports.
Namespace: Tekla.Structures.Model.Operations
Assembly: Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.3
Syntax
Parameters
- FileName
- Type: SystemString
The name of the report to display. The name must contain more than three characters.
Return Value
Type: BooleanTrue if the report existed.
Exceptions
Exception | Condition |
---|---|
ArgumentException | Thrown when the file specified in the FileName is not found or when the FileName is too short. |
See Also