OperationDisplayPrompt Method |
Displays a message in the status bar.
Namespace: Tekla.Structures.Model.Operations
Assembly: Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.3
Syntax
Parameters
- Message
- Type: SystemString
The message to display.
Return Value
Type: BooleanTrue if the message could be displayed.
Exceptions
Exception | Condition |
---|---|
ArgumentNullException | Thrown when the Message is null. |
Remarks
Prompts
Tekla Structures prefixes the given prompt with "prompt_" and looks for a translation in the prompts.ail file. If the translation (e.g. "prompt_Pick_first_position") is not found in the prompts.ail file, the prompt string is displayed as such. This feature can be used to give already translated strings to the picker.
See Also