DimensionSetBaseAttributesDimensionValueFormats Enumeration |
The dimension value formats.
Namespace: Tekla.Structures.Drawing
Assembly: Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.3
Syntax
Members
Member name | Value | Description | |
---|---|---|---|
NoDecimals | 0 | The value is with no decimals. | |
OneOptionalDecimal | 1 | The value is with one decimal if the value is not whole. | |
OneDecimal | 2 | The value is with one decimal. | |
TwoOptionalDecimals | 3 | The value is with two decimals if the value is not whole. | |
TwoDecimals | 4 | The value is with two decimals. | |
ThreeOptionalDecimals | 5 | The value is with three decimals if the value is not whole. | |
ThreeDecimals | 6 | The value is with three decimals. | |
RationalPart | 7 | The value is with a rational part. | |
SuperscriptEnding | 8 | The value is with superscript ending. |
See Also