DimensionSetBaseAttributesDimensionTextAttributes Class |
The DimensionTextAttributes class controls the dimension value representation.
Inheritance Hierarchy
SystemObject
Tekla.Structures.DrawingGenericAttributesBase
Tekla.Structures.DrawingDimensionSetBaseAttributesDimensionTextAttributes
Tekla.Structures.DrawingGenericAttributesBase
Tekla.Structures.DrawingDimensionSetBaseAttributesDimensionTextAttributes
Namespace: Tekla.Structures.Drawing
Assembly: Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.3
Syntax
The DimensionSetBaseAttributesDimensionTextAttributes type exposes the following members.
Constructors
Name | Description | |
---|---|---|
DimensionSetBaseAttributesDimensionTextAttributes |
Creates a new dimension text attributes instance. By default the default font is used, no frame is drawn
and the value text is above the dimension line.
| |
DimensionSetBaseAttributesDimensionTextAttributes(FontAttributes, DimensionSetBaseAttributesFrameTypes, DimensionSetBaseAttributesDimensionTextPlacings) |
Creates a new dimension text attributes instance with the given parameters.
|
Properties
Name | Description | |
---|---|---|
Font |
The font attributes.
| |
Frame |
The frame type of the dimension value text.
| |
TextPlacing |
The place of the dimension value text.
|
Methods
Name | Description | |
---|---|---|
IsEqual |
Compares the current object with an object of the same type.
(Overrides GenericAttributesBaseIsEqual(Object).) |
See Also