DimensionSetBaseAttributesCombinedDimensionAttributes Class |
The CombinedDimensionAttributes class handles attributes related to
the combination of identical parts of dimensions.
Inheritance Hierarchy
SystemObject
Tekla.Structures.DrawingGenericAttributesBase
Tekla.Structures.DrawingDimensionSetBaseAttributesCombinedDimensionAttributes
Tekla.Structures.DrawingGenericAttributesBase
Tekla.Structures.DrawingDimensionSetBaseAttributesCombinedDimensionAttributes
Namespace: Tekla.Structures.Drawing
Assembly: Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.3
Syntax
The DimensionSetBaseAttributesCombinedDimensionAttributes type exposes the following members.
Constructors
Name | Description | |
---|---|---|
DimensionSetBaseAttributesCombinedDimensionAttributes |
Creates a new combined dimension attributes instance.
The defaults combine a minimum of three identical dimensions to be
shown as the number of items times the length of the dimension.
| |
DimensionSetBaseAttributesCombinedDimensionAttributes(Int32, DimensionSetBaseAttributesCombineFormats) |
Creates a new combined dimension attributes instance with the given parameters.
|
Properties
Name | Description | |
---|---|---|
Format |
The combined dimension format.
| |
MinimumNumberToCombine |
The minimum number of dimensions to be combined.
|
Methods
Name | Description | |
---|---|---|
IsEqual |
Compares the current object with an object of the same type.
(Overrides GenericAttributesBaseIsEqual(Object).) |
See Also