Detail Class |
The Detail class represents a detail. A detail is different from a connection since the detail only connects to one part.
Inheritance Hierarchy
SystemObject
Tekla.Structures.ModelObject
Tekla.Structures.ModelModelObject
Tekla.Structures.ModelBaseComponent
Tekla.Structures.ModelDetail
Tekla.Structures.ModelObject
Tekla.Structures.ModelModelObject
Tekla.Structures.ModelBaseComponent
Tekla.Structures.ModelDetail
Namespace: Tekla.Structures.Model
Assembly: Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.3
Syntax
The Detail type exposes the following members.
Constructors
Properties
Name | Description | |
---|---|---|
AutoDirectionType |
The auto direction type. Default value is AUTODIR_DETAIL.
Value should be AUTODIR_NA to set direction with UpVector property.
Value should be AUTODIR_FROM_ATTRIBUTE_FILE to set direction with detail attribute file.
| |
Class |
The class of the detail.
| |
Code |
The code of the detail. The code can be used to classify the detail.
The code can be reported and shown in drawings.
The maximum length of the string is 20 characters.
| |
DetailType |
The detail type.
| |
Identifier |
The identifier of the object.
(Inherited from Object.) | |
IsUpToDate | Gets if the object does not have a modification which is not shared. (Inherited from ModelObject.) | |
ModificationTime | Gets latest time of the object was modified or created. (Inherited from ModelObject.) | |
Name |
The name of the component. The name identifies custom components or plug-ins.
(Inherited from BaseComponent.) | |
Number |
The number of the component. A number greater than zero identifies system components,
for custom components the number is CUSTOM_OBJECT_NUMBER, and for plug-ins the number is PLUGIN_OBJECT_NUMBER.
(Inherited from BaseComponent.) | |
PositionType |
The position type.
| |
Status |
The read only status of the detail.
The status can be reported and shown in drawings.
The color of the detail symbol in the model indicates the status of the detail.
| |
UpVector |
A vector indicating which direction is considered the up direction.
|
Methods
Name | Description | |
---|---|---|
CompareTo |
Compares Identifiers of model objects.
(Inherited from ModelObject.) | |
Delete |
Deletes the detail instance with the given ID from the model database.
(Overrides ModelObjectDelete.) | |
Equals |
Check if Identifiers of model objects are same.
(Inherited from ModelObject.) | |
GetAllReportProperties |
Retrieves all properties for the model object in one hashtable.
Type for the returned value must be checked using type casting.
(Inherited from ModelObject.) | |
GetAllUserProperties |
Retrieves all properties for the model object in one hashtable.
Type for the returned value must be checked using type casting.
(Inherited from ModelObject.) | |
GetAttribute(String, Double) |
Retrieves the attribute with the given name.
(Inherited from BaseComponent.) | |
GetAttribute(String, Int32) |
Retrieves the attribute with the given name.
(Inherited from BaseComponent.) | |
GetAttribute(String, String) |
Retrieves the attribute with the given name.
(Inherited from BaseComponent.) | |
GetChildren |
Returns an enumerator of all the children model objects.
(Inherited from ModelObject.) | |
GetCoordinateSystem |
Returns the coordinate system for the given model object.
(Inherited from ModelObject.) | |
GetDoubleReportProperties |
Retrieves multiple double report properties for the model object. It is faster
to fetch multiple properties at once.
(Inherited from ModelObject.) | |
GetDoubleUserProperties |
Retrieves all double properties for the model object.
(Inherited from ModelObject.) | |
GetDynamicStringProperty |
Gets a dynamic string property from the model object.
(Inherited from ModelObject.) | |
GetFatherComponent |
Returns the father component of the model object.
(Inherited from ModelObject.) | |
GetHierarchicObjects |
Returns an enumerator of all the connected hierarchic objects.
(Inherited from ModelObject.) | |
GetIntegerReportProperties |
Retrieves multiple integer report properties for the model object. It is faster
to fetch multiple properties at once.
(Inherited from ModelObject.) | |
GetIntegerUserProperties |
Retrieves all integer properties for the model object.
(Inherited from ModelObject.) | |
GetPhase |
Retrieves the phase of the model object (the phase number, the phase name,
the phase comment and whether the phase is the current one or not).
(Inherited from ModelObject.) | |
GetPrimaryObject |
Returns the primary object.
| |
GetReferencePoint |
Returns the reference point.
| |
GetReportProperty(String, Double) |
Retrieves a double property of the report for the model object.
(Inherited from ModelObject.) | |
GetReportProperty(String, Int32) |
Retrieves an integer property of the report for the model object.
(Inherited from ModelObject.) | |
GetReportProperty(String, String) |
Retrieves a string property of the report for the model object.
(Inherited from ModelObject.) | |
GetStringReportProperties |
Retrieves multiple string report properties for the model object. It is faster
to fetch multiple properties at once.
(Inherited from ModelObject.) | |
GetStringUserProperties |
Retrieves all string properties for the model object.
(Inherited from ModelObject.) | |
GetUserProperty(String, Double) |
Retrieves a double property for the model object.
(Inherited from ModelObject.) | |
GetUserProperty(String, Int32) |
Retrieves an integer property for the model object.
(Inherited from ModelObject.) | |
GetUserProperty(String, String) |
Retrieves a string property for the model object.
(Inherited from ModelObject.) | |
Insert |
Inserts the detail into the model database. All the attributes must be set.
(Overrides ModelObjectInsert.) | |
LoadAttributesFromFile |
Loads the attributes for the component from the given file. These attributes
will be loaded before all the attributes that have been set with the SetAttribute
methods, so any attributes that are set with SetAttribute will override those
loaded from the given standard file.
(Inherited from BaseComponent.) | |
Modify |
Modifies the existing detail in the model database to match the current one.
(Overrides ModelObjectModify.) | |
Select |
Selects a detail from the model database. The detail ID must be set.
(Overrides ModelObjectSelect.) | |
SetAttribute(String, Double) |
Sets the attribute's value to the given value.
(Inherited from BaseComponent.) | |
SetAttribute(String, Int32) |
Sets the attribute's value to the given value.
(Inherited from BaseComponent.) | |
SetAttribute(String, String) |
Sets the attribute's value to the given value.
(Inherited from BaseComponent.) | |
SetDynamicStringProperty |
Sets a dynamic string property for the model object.
(Inherited from ModelObject.) | |
SetLabel |
Sets a label for an object when a new instance is created, this method must be called before Insert.
The label is used in plug-ins for identifying the changed object in modification.
(Inherited from ModelObject.) | |
SetPhase |
Sets the phase of the model object.
(Inherited from ModelObject.) | |
SetPrimaryObject |
Sets the detail's primary object.
| |
SetReferencePoint |
Sets the reference point; the point the user would pick for the detail to appear to.
| |
SetUserProperties |
Sets multiple properties for the model object.
(Inherited from ModelObject.) | |
SetUserProperty(String, Double) |
Sets a double property for the model object.
(Inherited from ModelObject.) | |
SetUserProperty(String, Int32) |
Sets an integer property for the model object.
(Inherited from ModelObject.) | |
SetUserProperty(String, String) |
Sets a string property for the model object.
(Inherited from ModelObject.) |
Examples
using Tekla.Structures.Model; using Tekla.Structures.Geometry3d; using Tekla.Structures; using System; public class Example { public void Example1() { Beam B = new Beam(new Point(13000,3000,-500), new Point(13000,3000,6000)); B.Profile.ProfileString = "HEA400"; B.Material.MaterialString = "S235JR"; if(B.Insert()) { Detail D = new Detail(); D.Name = "Test End Plate Detail"; D.Number = 1002; D.LoadAttributesFromFile("standard"); D.UpVector = new Vector(0,0,0); D.PositionType = PositionTypeEnum.MIDDLE_PLANE; D.AutoDirectionType = AutoDirectionTypeEnum.AUTODIR_DETAIL; D.DetailType = DetailTypeEnum.END; D.SetPrimaryObject(B); D.SetReferencePoint(new Point(13000,3000,3000)); D.SetAttribute("el", 33.0); D.SetAttribute("er", 33.0); if(!D.Insert()) { Console.WriteLine("Detail Insert failed"); } else { Console.WriteLine(D.Identifier.ID); Double DValue = 0.0; if(!D.GetAttribute("er", ref DValue) || DValue != 33) Console.WriteLine("Detail GetAttribute failed"); } } } }
See Also