AnalysisResultDelete Method

Delete analysis results by the given key.

Namespace:  Tekla.Structures.Analysis
Assembly:  Tekla.Structures.Analysis (in Tekla.Structures.Analysis.dll) Version: 2023.0.3
Syntax
public static bool Delete(
	AnalysisResultObjectTypeEnum objectType,
	int objectId
)

Parameters

objectType
Type: Tekla.Structures.AnalysisAnalysisResultObjectTypeEnum
Object type.
objectId
Type: SystemInt32
Object id.

Return Value

Type: Boolean
True if successful.
Examples
Delete all analysis results of part.
var result = AnalysisResult.Delete(AnalysisResult.ObjectTypeEnum.OBJECT_TYPE_PART, analysisPart.PartID.ID);
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next