DrawingPluginBaseDefineInput Method

The method Tekla Structures calls for the plug-in to query the input. The plug-in must then return an array list of input definition instances. The plug-in will be dependent on the items it returns. Dependent means that if any of these items change, for example the user moves the points, the plug-in will be re-run with new input. DefineInput is not called during the re-run, and thus all the actual implementation should be in the Run() method. The Run() method is always called in view coordinates.

Namespace:  Tekla.Structures.Plugins
Assembly:  Tekla.Structures.Plugins (in Tekla.Structures.Plugins.dll) Version: 2023.0.3
Syntax
public abstract List<DrawingPluginBaseInputDefinition> DefineInput()

Return Value

Type: ListDrawingPluginBaseInputDefinition
An array list of input definition instances. If the plug-in is not dependent on input, it should return an empty array list (not null).
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next