![]() | DistanceToDecimalString Method (String) |
Converts the distance to a decimal string representation.
Namespace: Tekla.Structures.Datatype
Assembly: Tekla.Structures.Datatype (in Tekla.Structures.Datatype.dll) Version: 2023.0.3
![](/modules/custom/trimble_html_import/icons/SectionExpanded.png)
Parameters
- format
- Type: SystemString
The format string.
Return Value
Type: StringThe string representation of the distance.
![](/modules/custom/trimble_html_import/icons/SectionExpanded.png)
This example shows how to specify a number format when converting a
Distance instance into a decimal string.
using Tekla.Structures.Datatype; public class Example { public void Example1() { // For this demonstration, we'll format 300.2 millimeters. Distance distance = new Distance(300.2); string formattedString = distance.ToDecimalString("0.00"); } }
![](/modules/custom/trimble_html_import/icons/SectionExpanded.png)