CustomPartPositioningTypeAttribute Class |
The CustomPartInputTypeAttribute class is used for defining the input type.
Based on the type the system will then position the custom part either based on calculated
extrema center point or given input points.
The attribute is initialized from the custom attribute i.e.
[CustomPartPositioningType((CustomPartBase.CustomPartPositioningType.POSITIONING_BY_INPUTPOINTS)]
in the custom part source code.
Inheritance Hierarchy
Namespace: Tekla.Structures.Plugins
Assembly: Tekla.Structures.Plugins (in Tekla.Structures.Plugins.dll) Version: 2023.0.3
Syntax
The CustomPartPositioningTypeAttribute type exposes the following members.
Constructors
Name | Description | |
---|---|---|
CustomPartPositioningTypeAttribute(Int32) |
The custom attribute uses this to store the positioning type to the system.
This is not to be used by itself.
| |
CustomPartPositioningTypeAttribute(CustomPartBaseCustomPartPositioningType) |
The custom attribute uses this to store the positioning type to the system.
This is not to be used by itself.
|
Properties
Name | Description | |
---|---|---|
Type |
The custom attribute uses this to store the positioning type to the system.
This is not to be used by itself.
|
See Also