CustomPart Class |
The CustomPart class represents a custom part object in the Tekla Structures model.
A custom part is a modeling tool that typically assembles multiple parts to build some
type of a beam-like structure, for example a tapered beam or a sandwich panel.
Inheritance Hierarchy
SystemObject
Tekla.Structures.ModelObject
Tekla.Structures.ModelModelObject
Tekla.Structures.ModelBaseComponent
Tekla.Structures.ModelCustomPart
Tekla.Structures.ModelObject
Tekla.Structures.ModelModelObject
Tekla.Structures.ModelBaseComponent
Tekla.Structures.ModelCustomPart
Namespace: Tekla.Structures.Model
Assembly: Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.3
Syntax
The CustomPart type exposes the following members.
Constructors
Name | Description | |
---|---|---|
CustomPart |
Creates a new custom part instance.
| |
CustomPart(Point, Point) |
Creates a new custom part instance with the given input.
|
Properties
Name | Description | |
---|---|---|
Identifier |
The identifier of the object.
(Inherited from Object.) | |
IsUpToDate | Gets if the object does not have a modification which is not shared. (Inherited from ModelObject.) | |
ModificationTime | Gets latest time of the object was modified or created. (Inherited from ModelObject.) | |
Name |
The name of the component. The name identifies custom components or plug-ins.
(Inherited from BaseComponent.) | |
Number |
The number of the component. A number greater than zero identifies system components,
for custom components the number is CUSTOM_OBJECT_NUMBER, and for plug-ins the number is PLUGIN_OBJECT_NUMBER.
(Inherited from BaseComponent.) | |
Position |
The way the custom part is positioned in the model.
|
Methods
Name | Description | |
---|---|---|
CompareTo |
Compares Identifiers of model objects.
(Inherited from ModelObject.) | |
Delete |
Deletes the custom part instance with the given identifier from the model database.
(Overrides ModelObjectDelete.) | |
Equals |
Check if Identifiers of model objects are same.
(Inherited from ModelObject.) | |
GetAllReportProperties |
Retrieves all properties for the model object in one hashtable.
Type for the returned value must be checked using type casting.
(Inherited from ModelObject.) | |
GetAllUserProperties |
Retrieves all properties for the model object in one hashtable.
Type for the returned value must be checked using type casting.
(Inherited from ModelObject.) | |
GetAssembly |
Returns the assembly that the custom part belongs to.
| |
GetAttribute(String, Double) |
Retrieves the attribute with the given name.
(Inherited from BaseComponent.) | |
GetAttribute(String, Int32) |
Retrieves the attribute with the given name.
(Inherited from BaseComponent.) | |
GetAttribute(String, String) |
Retrieves the attribute with the given name.
(Inherited from BaseComponent.) | |
GetBooleans |
Returns an enumerator of all the connected boolean objects.
| |
GetChildren |
Returns an enumerator of all the children model objects.
(Inherited from ModelObject.) | |
GetComponents |
Returns an enumerator of all the connected components.
| |
GetCoordinateSystem |
Returns the coordinate system for the given model object.
(Inherited from ModelObject.) | |
GetDoubleReportProperties |
Retrieves multiple double report properties for the model object. It is faster
to fetch multiple properties at once.
(Inherited from ModelObject.) | |
GetDoubleUserProperties |
Retrieves all double properties for the model object.
(Inherited from ModelObject.) | |
GetDynamicStringProperty |
Gets a dynamic string property from the model object.
(Inherited from ModelObject.) | |
GetFatherComponent |
Returns the father component of the model object.
(Inherited from ModelObject.) | |
GetHierarchicObjects |
Returns an enumerator of all the connected hierarchic objects.
(Inherited from ModelObject.) | |
GetIntegerReportProperties |
Retrieves multiple integer report properties for the model object. It is faster
to fetch multiple properties at once.
(Inherited from ModelObject.) | |
GetIntegerUserProperties |
Retrieves all integer properties for the model object.
(Inherited from ModelObject.) | |
GetPhase |
Retrieves the phase of the model object (the phase number, the phase name,
the phase comment and whether the phase is the current one or not).
(Inherited from ModelObject.) | |
GetReportProperty(String, Double) |
Retrieves a double property of the report for the model object.
(Inherited from ModelObject.) | |
GetReportProperty(String, Int32) |
Retrieves an integer property of the report for the model object.
(Inherited from ModelObject.) | |
GetReportProperty(String, String) |
Retrieves a string property of the report for the model object.
(Inherited from ModelObject.) | |
GetStartAndEndPositions |
Returns the start and end points of the custom part.
| |
GetStringReportProperties |
Retrieves multiple string report properties for the model object. It is faster
to fetch multiple properties at once.
(Inherited from ModelObject.) | |
GetStringUserProperties |
Retrieves all string properties for the model object.
(Inherited from ModelObject.) | |
GetUserProperty(String, Double) |
Retrieves a double property for the model object.
(Inherited from ModelObject.) | |
GetUserProperty(String, Int32) |
Retrieves an integer property for the model object.
(Inherited from ModelObject.) | |
GetUserProperty(String, String) |
Retrieves a string property for the model object.
(Inherited from ModelObject.) | |
Insert |
Inserts the custom part into the model database.
(Overrides ModelObjectInsert.) | |
LoadAttributesFromFile |
Loads the attributes for the component from the given file. These attributes
will be loaded before all the attributes that have been set with the SetAttribute
methods, so any attributes that are set with SetAttribute will override those
loaded from the given standard file.
(Inherited from BaseComponent.) | |
Modify |
Modifies the existing custom part in the model database to match the current one.
(Overrides ModelObjectModify.) | |
Select |
Selects a custom part from the model database. The custom part identifier must be set.
(Overrides ModelObjectSelect.) | |
SetAttribute(String, Double) |
Sets the attribute's value to the given value.
(Inherited from BaseComponent.) | |
SetAttribute(String, Int32) |
Sets the attribute's value to the given value.
(Inherited from BaseComponent.) | |
SetAttribute(String, String) |
Sets the attribute's value to the given value.
(Inherited from BaseComponent.) | |
SetDynamicStringProperty |
Sets a dynamic string property for the model object.
(Inherited from ModelObject.) | |
SetInputPositions |
Sets the start and end point of the custom part.
| |
SetLabel |
Sets a label for an object when a new instance is created, this method must be called before Insert.
The label is used in plug-ins for identifying the changed object in modification.
(Inherited from ModelObject.) | |
SetPhase |
Sets the phase of the model object.
(Inherited from ModelObject.) | |
SetUserProperties |
Sets multiple properties for the model object.
(Inherited from ModelObject.) | |
SetUserProperty(String, Double) |
Sets a double property for the model object.
(Inherited from ModelObject.) | |
SetUserProperty(String, Int32) |
Sets an integer property for the model object.
(Inherited from ModelObject.) | |
SetUserProperty(String, String) |
Sets a string property for the model object.
(Inherited from ModelObject.) |
Examples
using Tekla.Structures.Model; using Tekla.Structures.Geometry3d; public class Example { public void Example1() { CustomPart CPart = new CustomPart(); CPart.Name = "HPKM39"; CPart.Number = BaseComponent.CUSTOM_OBJECT_NUMBER; CPart.Position.Plane = Position.PlaneEnum.LEFT; CPart.Position.PlaneOffset = 10; CPart.Position.Depth = Position.DepthEnum.BEHIND; CPart.Position.DepthOffset = 30; CPart.Position.RotationOffset = 45; CPart.Position.Rotation = Position.RotationEnum.TOP; CPart.SetInputPositions(new Point(100, 0, 0), new Point(300, 0, 0)); CPart.SetAttribute("P2a", "TEST"); CPart.Insert(); } }
See Also