CurvedDimensionSetRadial Class |
The CurvedDimensionSetRadial class defines a curved dimension set with radial reference lines.
Inheritance Hierarchy
SystemObject
Tekla.Structures.DrawingDatabaseObject
Tekla.Structures.DrawingDrawingObject
Tekla.Structures.DrawingDimensionSetBase
Tekla.Structures.DrawingCurvedDimensionSetBase
Tekla.Structures.DrawingCurvedDimensionSetRadial
Tekla.Structures.DrawingDatabaseObject
Tekla.Structures.DrawingDrawingObject
Tekla.Structures.DrawingDimensionSetBase
Tekla.Structures.DrawingCurvedDimensionSetBase
Tekla.Structures.DrawingCurvedDimensionSetRadial
Namespace: Tekla.Structures.Drawing
Assembly: Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.3
Syntax
The CurvedDimensionSetRadial type exposes the following members.
Properties
Name | Description | |
---|---|---|
Attributes |
The curved dimension set radial attributes.
Distance |
Gets the distance.
Methods
Name | Description | |
---|---|---|
GetUserProperty(String, Double) |
Gets a double property from the drawing object. The object has to be in a drawing before
GetUserProperty(String, Int32) |
Gets an integer property from the drawing object. The object has to be in a drawing before
GetUserProperty(String, String) |
Gets a string property from the drawing object. The object has to be in a drawing before
IsEqual |
Compares the current object with an object of the same type.
SetUserProperty(String, Double) |
Sets a double property for the drawing object. The object has to be in a drawing before
SetUserProperty(String, Int32) |
Sets an integer property for the drawing object. The object has to be in a drawing before
SetUserProperty(String, String) |
Sets a string property for the drawing object. The object has to be in a drawing before
Examples
The following code asks the user to pick three points and then creates a
dimension between the points with a 50 mm distance:
using Tekla.Structures.Drawing; using Tekla.Structures.Drawing.UI; using Tekla.Structures.Geometry3d; public class Example { static void PickPoints(int numberToPick, ref PointList pointList, ref ViewBase view) { Picker picker = new DrawingHandler().GetPicker(); Point point; while (--numberToPick != -1) { picker.PickPoint("Pick point", out point, out view); pointList.Add(point); } } static void CreateDimension() { double Distance = 50.0; PointList pointList = new PointList(); ViewBase view = null; PickPoints(3, ref pointList, ref view); new CurvedDimensionSetHandler().CreateCurvedDimensionSetRadial(view, pointList[0], pointList[1], pointList[2], pointList, Distance); } }
See Also