CurvedDimensionSetBaseCurvedDimensionSetBaseAttributes Class |
The CurvedDimensionSetBaseAttributes class contains the attributes for the curved dimensions.
Inheritance Hierarchy
SystemObject
Tekla.Structures.DrawingAttributesBase
Tekla.Structures.DrawingDimensionSetBaseAttributes
Tekla.Structures.DrawingCurvedDimensionSetBaseCurvedDimensionSetBaseAttributes
Tekla.Structures.DrawingCurvedDimensionSetOrthogonalCurvedDimensionSetOrthogonalAttributes
Tekla.Structures.DrawingCurvedDimensionSetRadialCurvedDimensionSetRadialAttributes
Tekla.Structures.DrawingAttributesBase
Tekla.Structures.DrawingDimensionSetBaseAttributes
Tekla.Structures.DrawingCurvedDimensionSetBaseCurvedDimensionSetBaseAttributes
Tekla.Structures.DrawingCurvedDimensionSetOrthogonalCurvedDimensionSetOrthogonalAttributes
Tekla.Structures.DrawingCurvedDimensionSetRadialCurvedDimensionSetRadialAttributes
Namespace: Tekla.Structures.Drawing
Assembly: Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.3
Syntax
The CurvedDimensionSetBaseCurvedDimensionSetBaseAttributes type exposes the following members.
Constructors
Name | Description | |
---|---|---|
CurvedDimensionSetBaseCurvedDimensionSetBaseAttributes |
Creates a new curved dimension set base attributes instance which loads standard attributes.
| |
CurvedDimensionSetBaseCurvedDimensionSetBaseAttributes(String) |
Creates a new curved dimension set base attributes instance that loads the specified attributes.
|
Properties
Name | Description | |
---|---|---|
Arrowhead |
The arrowhead attributes of the dimension.
(Inherited from DimensionSetBaseAttributes.) | |
Color |
The color of the dimension line.
(Inherited from DimensionSetBaseAttributes.) | |
Format |
The format attributes of the dimension.
(Inherited from DimensionSetBaseAttributes.) | |
Placing |
The placing attributes of the dimension.
(Inherited from DimensionSetBaseAttributes.) | |
Text |
The text attributes of the dimension.
(Inherited from DimensionSetBaseAttributes.) | |
TransparentBackground |
The dimension text background transparency. (transparent/opaque)
(Inherited from DimensionSetBaseAttributes.) |
Methods
Name | Description | |
---|---|---|
IsEqual |
Compares the current object with an object of the same type.
(Inherited from AttributesBase.) | |
LoadAttributes |
Loads the attributes from the specified file.
(Inherited from AttributesBase.) |
See Also