OperationCreateNCFilesFromAll Method (String, String) |
Creates NC files from all parts using the given NC template name.
See Tekla Structures Help for more information about NC files.
Namespace: Tekla.Structures.Model.Operations
Assembly: Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.3
Syntax
Parameters
- NCFileSettings
- Type: SystemString
The name of the NC setting template to be used in creation. - DestinationFolder
- Type: SystemString
The name of the folder where NC files are created. If defined, overrides the default folder in the setting template.
Return Value
Type: BooleanTrue if the NC files are created, false if the numbering is not up-to-date or the used configuration is wrong.
Exceptions
Exception | Condition |
---|---|
ArgumentException | Thrown when the NCFileSettings is not defined. |
ArgumentNullException | Thrown when the NCFileSettings is null. |
Examples
using Tekla.Structures.Model.Operations; using System.Windows.Forms; public class Example { public void Example1() { if (Operation.CreateNCFilesFromAll("DSTV for plates", "")) MessageBox.Show("NC creation successful"); } }
See Also