InputDefinitionFactoryCreateInputDefinition Method (ViewBase, Point, Point, Point) |
Creates a three-point input definition.
Namespace: Tekla.Structures.Drawing.Tools
Assembly: Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.3
Syntax
public static DrawingPluginBaseInputDefinition CreateInputDefinition( ViewBase view, Point point1, Point point2, Point point3 )
Parameters
- view
- Type: Tekla.Structures.DrawingViewBase
The view to be used in the input. - point1
- Type: Tekla.Structures.Geometry3dPoint
The first point to be used in the input. - point2
- Type: Tekla.Structures.Geometry3dPoint
The second point to be used in the input. - point3
- Type: Tekla.Structures.Geometry3dPoint
The third point to be used in the input.
Return Value
Type: DrawingPluginBaseInputDefinitionThe input definition.
See Also