ViewCreateFrontView Method |
Generates a new front view on the sheet of the given drawing.
Namespace: Tekla.Structures.Drawing
Assembly: Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.3
Syntax
public static bool CreateFrontView( Drawing drawing, Point viewInsertionPoint, ViewViewAttributes viewAttributes, out View view )
Parameters
- drawing
- Type: Tekla.Structures.DrawingDrawing
The drawing in which to create the view. - viewInsertionPoint
- Type: Tekla.Structures.Geometry3dPoint
The center point of the view. - viewAttributes
- Type: Tekla.Structures.DrawingViewViewAttributes
The attributes for the view to be created. - view
- Type: Tekla.Structures.DrawingView
The created view is returned if the creation was successful. Otherwise, null is returned.
Return Value
Type: BooleanTrue if the view was created successfully.
Exceptions
Exception | Condition |
---|---|
InvalidTypeException | Thrown if given drawing is GA drawing. |
TeklaStructuresDrawingsApplicationException | Thrown if an unknown error occurrs. |
See Also