DrawingCreatorCreateDrawings Method (AutoDrawingRule, Identifier, AutoDrawingsStatusEnum) |
Creates drawings using the AutoDrawing tool of Tekla Structures.
Namespace: Tekla.Structures.Drawing.Automation
Assembly: Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.3
Syntax
public static bool CreateDrawings( AutoDrawingRule Rule, Identifier ModelObjectIdentifier, out AutoDrawingsStatusEnum OperationStatus )
Parameters
- Rule
- Type: Tekla.Structures.Drawing.AutomationAutoDrawingRule
The AutoDrawing rule to be used. - ModelObjectIdentifier
- Type: Tekla.StructuresIdentifier
The model object identifier to be used. Part identifier to create single part drawing or assembly identifier to create assembly drawing. - OperationStatus
- Type: Tekla.Structures.Drawing.AutomationAutoDrawingsStatusEnum
The operation status to be used.
Return Value
Type: BooleanTrue on success.
See Also