OperationCreateDGNv8Export Method

Dgn export from all or selected objects.

Namespace:  Tekla.Structures.Model.Operations
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.3
Syntax
public static bool CreateDGNv8Export(
	string FileName,
	string Folder,
	OperationExportBasePoint BasePoint,
	string BasePointGuid,
	string ObjectColoring,
	string ExportLayersAs,
	bool OnlyFromSelectedObjects
)

Parameters

FileName
Type: SystemString
The file name.
Folder
Type: SystemString
The folder.
BasePoint
Type: Tekla.Structures.Model.OperationsOperationExportBasePoint
Defines which base point is used in export.
BasePointGuid
Type: SystemString
Base point guid if BasePoint parameter is set to BASE_POINT.
ObjectColoring
Type: SystemString
Defines which object coloring filter is to be used in export.
ExportLayersAs
Type: SystemString
Defines which report field to use for layers export.
OnlyFromSelectedObjects
Type: SystemBoolean
Defines if only selected (value true) or all (value false) objects are exported.

Return Value

Type: Boolean
bool, defines the final run state.
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next