ViewCreateDetailView Method |
Generates a new detail view on the sheet and the associated detail mark for the specified view.
Namespace: Tekla.Structures.Drawing
Assembly: Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.3
Syntax
public static bool CreateDetailView( View view, Point centerPoint, Point boundaryPoint, Point labelPoint, Point viewInsertionPoint, ViewViewAttributes viewAttributes, DetailMarkDetailMarkAttributes detailMarkAttributes, out View detailView, out DetailMark detailMark )
Parameters
- view
- Type: Tekla.Structures.DrawingView
The view in which to place the detail mark. - centerPoint
- Type: Tekla.Structures.Geometry3dPoint
The center point of the detail mark. - boundaryPoint
- Type: Tekla.Structures.Geometry3dPoint
The boundary point of the detail mark. - labelPoint
- Type: Tekla.Structures.Geometry3dPoint
The label point of the detail mark label. - viewInsertionPoint
- Type: Tekla.Structures.Geometry3dPoint
The point where to create the detail view. - viewAttributes
- Type: Tekla.Structures.DrawingViewViewAttributes
The attributes for the detail view to be created. - detailMarkAttributes
- Type: Tekla.Structures.DrawingDetailMarkDetailMarkAttributes
The attributes for the detail mark to be created. - detailView
- Type: Tekla.Structures.DrawingView
The created detail view is returned if the creation was successful. Otherwise, null is returned. - detailMark
- Type: Tekla.Structures.DrawingDetailMark
The created detail mark is returned if the creation was successful. Otherwise, null is returned.
Return Value
Type: BooleanTrue if the detail view was created successfully.
See Also