CurvedDimensionSetHandlerCreateCurvedDimensionSetOrthogonal Method (ViewBase, Point, Point, Point, PointList, Double) |
Creates a curved dimension set with orthogonal reference lines
from the specified points and inserts it to the database.
Namespace: Tekla.Structures.Drawing
Assembly: Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.3
Syntax
public CurvedDimensionSetOrthogonal CreateCurvedDimensionSetOrthogonal( ViewBase View, Point ArcPoint1, Point ArcPoint2, Point ArcPoint3, PointList DimensionPoints, double Distance )
Parameters
- View
- Type: Tekla.Structures.DrawingViewBase
The view to be used. - ArcPoint1
- Type: Tekla.Structures.Geometry3dPoint
The first arc point to be used. - ArcPoint2
- Type: Tekla.Structures.Geometry3dPoint
The second arc point to be used. - ArcPoint3
- Type: Tekla.Structures.Geometry3dPoint
The third arc point to be used. - DimensionPoints
- Type: Tekla.Structures.DrawingPointList
The dimension points to be used. - Distance
- Type: SystemDouble
The distance to be used.
Return Value
Type: CurvedDimensionSetOrthogonalThe created dimension set or null if failed.
See Also