ContainerElementCopyTo Method |
Namespace: Tekla.Structures.Drawing
Assembly: Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.3
Syntax
Parameters
- array
- Type: SystemArray
The one-dimensional Array that is the destination of the elements copied from the ICollection. The Array must have zero-based indexing. - index
- Type: SystemInt32
The zero-based index in the array at which copying begins.
Implements
ICollectionCopyTo(Array, Int32)Exceptions
Exception | Condition |
---|---|
ArgumentNullException | The array is null. |
ArgumentOutOfRangeException | The index is less than zero. |
ArgumentException | The array is multidimensional, or the index is equal to or greater than the length of the array, or the number of elements in the source ICollection is greater than the available space from the index to the end of the destination array. |
InvalidCastException | The type of the source ICollection cannot be cast automatically to the type of the destination array. |
See Also