CoordinateSystem Class |
The CoordinateSystem class defines a coordinate system in space. The system is
defined by an origin, an X-axis and a Y-axis. The Z-axis is the cross product of the X-axis and the Y-axis.
Inheritance Hierarchy
Namespace: Tekla.Structures.Geometry3d
Assembly: Tekla.Structures (in Tekla.Structures.dll) Version: 2023.0.3
Syntax
The CoordinateSystem type exposes the following members.
Constructors
Name | Description | |
---|---|---|
CoordinateSystem |
Instantiates a coordinate system in the current work plane.
| |
CoordinateSystem(Point, Vector, Vector) |
Instantiates a coordinate system with the given origin, X-axis and Y-axis.
|
Properties
Name | Description | |
---|---|---|
AxisX |
The X-axis of the coordinate system.
| |
AxisY |
The Y-axis of the coordinate system.
| |
Origin |
The origin of the coordinate system.
|
Examples
The following example creates a new coordinate system which is used to create a new view.
using System; using Tekla.Structures.Drawing; using Tekla.Structures.Geometry3d; public class Example { public void Example1() { Drawing GADrawing = new GADrawing(); CoordinateSystem CoordinateSystem = new CoordinateSystem(new Point(), new Vector(1, 0, 0), new Vector(0, 1, 0)); View newView = new View(GADrawing.GetSheet(), CoordinateSystem, CoordinateSystem, new AABB(new Point(0, 0), new Point(1000, 1000, 1000))); } }
See Also