DistanceConvertTo Method |
Converts the distance to the specified units.
Namespace: Tekla.Structures.Datatype
Assembly: Tekla.Structures.Datatype (in Tekla.Structures.Datatype.dll) Version: 2023.0.3
Syntax
Parameters
- unitType
- Type: Tekla.Structures.DatatypeDistanceUnitType
The distance unit type.
Return Value
Type: DoubleThe distance in the specified units.
Examples
This example shows how to convert a Distance instance into real
world units.
using Tekla.Structures.Datatype; public class Example { public void Example1() { // For this demonstration, we'll format 300.2 millimeters. Distance distance = new Distance(300.2); double distanceInInches = distance.ConvertTo(Distance.UnitType.Inch); } }
See Also