ControlArc Constructor (Point, Point, Point) |
Creates a new control arc instance taking the 3 points.
Namespace: Tekla.Structures.Model
Assembly: Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.3
Syntax
Parameters
- startPoint
- Type: Tekla.Structures.Geometry3dPoint
Start point of the arc. - endPoint
- Type: Tekla.Structures.Geometry3dPoint
End point of the arc. - pointOnArc
- Type: Tekla.Structures.Geometry3dPoint
Point that defines the arc.
Exceptions
Exception | Condition |
---|---|
ArgumentException | Throws when input points are not defined correctly |
See Also