Contour Class |
The Contour class defines a possibly chamfered contour. Contours must not have loops.
Inheritance Hierarchy
Namespace: Tekla.Structures.Model
Assembly: Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.3
Syntax
The Contour type exposes the following members.
Constructors
Properties
Name | Description | |
---|---|---|
ContourPoints |
The contour points belonging to the contour.
|
Methods
Name | Description | |
---|---|---|
AddContourPoint |
Adds a new contour point to the contour. Do not add the same contour point twice.
| |
CalculatePolygon |
Calculate a polygon approximating the contour with chamfers evaluated.
| |
GetPolycurve |
Gets the contour geometry as Polycurve
|
Fields
Name | Description | |
---|---|---|
MAX_CONTOUR_POINTS |
The maximum number of contour points that is typically valid in Tekla Structures.
| |
MIN_CONTOUR_POINTS |
The minimum number of contour points that is typically valid in Tekla Structures.
|
See Also