DistanceListContains Method

Determines whether the specified item is in the list.

Namespace:  Tekla.Structures.Datatype
Assembly:  Tekla.Structures.Datatype (in Tekla.Structures.Datatype.dll) Version: 2023.0.3
Syntax
Examples
This example shows how to determine whether the specified Distance instance is contained in a DistanceList.
using Tekla.Structures.Datatype;

public class Example
{
       public void Example1()
       {
           // We'll use this distance list to demonstrate the Contains method.
           DistanceList distanceList = new DistanceList(new Distance[]
                                                       {
                                                           new Distance(30.2),
                                                           new Distance(30.2),
                                                           new Distance(30.2),
                                                           new Distance(50),
                                                           new Distance(2.3),
                                                           new Distance(2.3),
                                                       });

           bool isInList = distanceList.Contains(new Distance(50));
       }
}
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next