ConnectiveGeometryException Class |
The ConnectiveGeometryException class represents an error that occurred during the ConnectiveGeometry creation or modification.
Inheritance Hierarchy
Namespace: Tekla.Structures.Model
Assembly: Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.3
Syntax
The ConnectiveGeometryException type exposes the following members.
Constructors
Name | Description | |
---|---|---|
ConnectiveGeometryException |
Initializes a new instance of the ConnectiveGeometryException class with general connective geometry error message.
| |
ConnectiveGeometryException(BentPlateGeometrySolverOperationStatus, String) |
Initializes a new instance of the ConnectiveGeometryException class with connective geometry error message based on status.
|
Fields
Name | Description | |
---|---|---|
OperationStatus |
Possible error statuses for geometry creation/modification commands.
|
See Also
Reference
Inheritance Hierarchy
SystemObject
SystemException
Tekla.Structures.ModelConnectiveGeometryException
Tekla.Structures.ModelExtensionIntersectsWithPlateException
Tekla.Structures.ModelFacePerpendicularToIntersectionLineException
Tekla.Structures.ModelFacesAtAnObtuseAngleException
Tekla.Structures.ModelFacesTooNearEachOtherException
Tekla.Structures.ModelGeneralConnectiveGeometryException
Tekla.Structures.ModelInvalidFacePointsException
Tekla.Structures.ModelInvalidRadiusException
Tekla.Structures.ModelPlateIntersectsWithIntersectionLineException
Tekla.Structures.ModelUndefinedCurveDirectionException
Tekla.Structures.ModelUnsupportedChamferException
SystemException
Tekla.Structures.ModelConnectiveGeometryException
Tekla.Structures.ModelExtensionIntersectsWithPlateException
Tekla.Structures.ModelFacePerpendicularToIntersectionLineException
Tekla.Structures.ModelFacesAtAnObtuseAngleException
Tekla.Structures.ModelFacesTooNearEachOtherException
Tekla.Structures.ModelGeneralConnectiveGeometryException
Tekla.Structures.ModelInvalidFacePointsException
Tekla.Structures.ModelInvalidRadiusException
Tekla.Structures.ModelPlateIntersectsWithIntersectionLineException
Tekla.Structures.ModelUndefinedCurveDirectionException
Tekla.Structures.ModelUnsupportedChamferException