ConicalSurface Class

The ConicalSurface class defines a conical surface contour.
Inheritance Hierarchy

Namespace:  Tekla.Structures.Model
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.3
Syntax
[SerializableAttribute]
public class ConicalSurface : BendSurface

The ConicalSurface type exposes the following members.

Constructors
  NameDescription
Public methodConicalSurface(Arc, Double, Double)
Initializes a new instance of the ConicalSurface class from a base arc, a height and a radius at the top. This is the recommended constructor if no intermediate points are desired along the lateral boundaries of the bend surface.
Public methodConicalSurface(ListPoint, ListPoint, Line, Vector)
Initializes a new instance of the ConicalSurface class from the cone lateral boundaries and the center line. This is the recommended constructor if fine grained control is desired over the lateral boundaries of the surface.
Public methodConicalSurface(Vector, Vector, ListPoint, ListPoint)
Initializes a new instance of the ConicalSurface class with given parameters. The boundaries are defined by the lateral boundaries (i.e. the points on the sides of the curved part of the cone). The side boundaries are defined by the two first points and the two last points of the lateral boundaries.
Public methodConicalSurface(Vector, Vector, LineSegment, LineSegment)
Initializes a new instance of the ConicalSurface class with given parameters. The boundaries are defined by the side boundaries (i.e. generator lines of the cone).
Top
Properties
  NameDescription
Public propertyApex
Gets the apex of the cone. If it does not exist, it returns null
Public propertyCenterLine
Gets the center line of the bend surface (i.e. the line that crosses every circular cross section of the bend at their center point)
(Inherited from BendSurface.)
Public propertyEndFaceNormal1
Gets the first end face normal.
(Inherited from BendSurface.)
Public propertyEndFaceNormal2
Gets the second end face normal.
(Inherited from BendSurface.)
Public propertyIntersectionLine
Gets intersection line.
(Inherited from BendSurface.)
Public propertyInwardCurved
Gets the direction of the curve - true if the curve is oriented towards the intersection line, false otherwise.
(Inherited from BendSurface.)
Public propertyLateralBoundary1
Gets or sets the first lateral boundary
(Inherited from BendSurface.)
Public propertyLateralBoundary2
Gets or sets the second lateral boundary
(Inherited from BendSurface.)
Public propertyRadiuses
Gets radiuses of the conical surface. The first radius corresponds to the section located in the first point of the side boundary 1, and the second radius corresponds to the section located in the second point of the side boundary 1.
Public propertyRotationAxis
Gets the unit vector that defines the rotation axis (for counter clockwise rotations) of the lateral boundaries of the surface. This axis is always parallel to the direction of the center line.
(Inherited from BendSurface.)
Public propertySideBoundary1
Gets or sets the first side boundary.
(Inherited from BendSurface.)
Public propertySideBoundary2
Gets or sets the second side boundary.
(Inherited from BendSurface.)
Top
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next