ComponentItem Class

The ComponentItem class contains information about the components in the Tekla Structures catalog.
Inheritance Hierarchy
SystemObject
  Tekla.Structures.CatalogsComponentItem

Namespace:  Tekla.Structures.Catalogs
Assembly:  Tekla.Structures.Catalogs (in Tekla.Structures.Catalogs.dll) Version: 2023.0.3
Syntax
[SerializableAttribute]
public class ComponentItem

The ComponentItem type exposes the following members.

Constructors
  NameDescription
Public methodComponentItem
Creates a new component item instance.
Top
Properties
  NameDescription
Public propertyAttributeFileExtension
Gets the attribute file extension of item from the component database.
Public propertyName
The component item's internal name which is used by Tekla Structures in component identification.
Public propertyNumber
The component item's internal number which is used by Tekla Structures in component identification.
Public propertyType
The component item's type.
Public propertyUIName
The component item's name which is visible in the Tekla Structures user interface.
Top
Methods
  NameDescription
Public methodCode exampleExport
Exports the custom component item in *.uel-format to the to given file name. If path is not given custom component is exported to model folder. If filename is empty custom component name is used as filename.
Public methodGetVersion
Gets the version number of custom component item from the component database.
Public methodSelect(String, Int32)
Selects the component item from the component database. Uses the type if defined for selection
Public methodSelect(String, Int32, ComponentItemComponentTypeEnum)
Selects the component item from the component database.
Top
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next