DistanceCompareTo Method

Compares the current object with another object of the same type.

Namespace:  Tekla.Structures.Datatype
Assembly:  Tekla.Structures.Datatype (in Tekla.Structures.Datatype.dll) Version: 2023.0.3
Syntax
public int CompareTo(
	Distance other
)

Parameters

other
Type: Tekla.Structures.DatatypeDistance
The object to be compared with the current object.

Return Value

Type: Int32

A 32-bit signed integer that indicates the relative order of the objects being compared.

The return value has the following meanings:

ValueMeaning
Less than zeroThe current object is less than the other object.
ZeroThe current object is equal to the other object.
Greater than zeroThe current object is greater than the other object.

Implements

IComparableTCompareTo(T)
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next