CloudCloudAttributes Class |
The CloudAttributes class is the attributes class for the cloud.
Inheritance Hierarchy
SystemObject
Tekla.Structures.DrawingAttributesBase
Tekla.Structures.DrawingGraphicObjectGraphicObjectAttributes
Tekla.Structures.DrawingClosedGraphicObjectClosedGraphicObjectAttributes
Tekla.Structures.DrawingCloudCloudAttributes
Tekla.Structures.DrawingAttributesBase
Tekla.Structures.DrawingGraphicObjectGraphicObjectAttributes
Tekla.Structures.DrawingClosedGraphicObjectClosedGraphicObjectAttributes
Tekla.Structures.DrawingCloudCloudAttributes
Namespace: Tekla.Structures.Drawing
Assembly: Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.3
Syntax
The CloudCloudAttributes type exposes the following members.
Constructors
Name | Description | |
---|---|---|
CloudCloudAttributes |
Creates a new default cloud attributes instance that loads standard attributes.
| |
CloudCloudAttributes(String) |
Creates a new cloud attributes instance that loads the specified attributes.
|
Properties
Name | Description | |
---|---|---|
BehindModelObjects |
Gets or sets whether the closed graphic object is drawn behind model objects
(Inherited from ClosedGraphicObjectClosedGraphicObjectAttributes.) | |
Hatch |
The hatch attributes of the closed graphic object (the closed graphic object is hatchable).
(Inherited from ClosedGraphicObjectClosedGraphicObjectAttributes.) | |
Line |
The line attributes of the graphic object. A graphic object always consists of lines.
(Inherited from GraphicObjectGraphicObjectAttributes.) |
Methods
Name | Description | |
---|---|---|
IsEqual |
Compares the current object with an object of the same type.
(Overrides AttributesBaseIsEqual(Object).) | |
LoadAttributes |
Loads the attributes from the attribute file.
(Overrides AttributesBaseLoadAttributes(String).) |
See Also