Cloud Class |
The Cloud class defines a cloud that is a polygon with a specific size set for the bulges.
Inheritance Hierarchy
SystemObject
Tekla.Structures.DrawingDatabaseObject
Tekla.Structures.DrawingDrawingObject
Tekla.Structures.DrawingGraphicObject
Tekla.Structures.DrawingClosedGraphicObject
Tekla.Structures.DrawingCloud
Tekla.Structures.DrawingDatabaseObject
Tekla.Structures.DrawingDrawingObject
Tekla.Structures.DrawingGraphicObject
Tekla.Structures.DrawingClosedGraphicObject
Tekla.Structures.DrawingCloud
Namespace: Tekla.Structures.Drawing
Assembly: Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.3
Syntax
The Cloud type exposes the following members.
Constructors
Name | Description | |
---|---|---|
Cloud(ViewBase, PointList) |
Creates a new cloud instance with a point list using standard attributes.
| |
Cloud(ViewBase, PointList, CloudCloudAttributes) |
Creates a new cloud instance with a point list using the given attributes.
|
Properties
Name | Description | |
---|---|---|
Attributes |
The attributes for the cloud.
| |
Bulge |
The bulge (curve) to use for the cloud (a bulge is the ratio between the height and width of an object).
| |
Hideable |
Accesses the information if this object is hidden or not or if it should be.
(Inherited from GraphicObject.) | |
Points |
The list of points for the cloud.
The points you insert will specify the corner points of the cloud.
After you insert the object, you will get every cloud point back.
| |
QueryReturnValue |
Status information about the latest database operation (select, insert, modify, delete).
(Inherited from DatabaseObject.) |
Methods
Name | Description | |
---|---|---|
Delete |
Calls the system to delete the object.
(Overrides DatabaseObjectDelete.) | |
GetDoubleUserProperties(DictionaryString, Double) |
Retrieves all double user properties for the object with the given list of names.
(Inherited from DatabaseObject.) | |
GetDoubleUserProperties(ListString, DictionaryString, Double) |
Retrieves all double user properties for the object with the given list of names.
(Inherited from DatabaseObject.) | |
GetDrawing |
Gets the drawing where the drawing object is.
(Inherited from DrawingObject.) | |
GetIntegerUserProperties(DictionaryString, Int32) |
Retrieves all integer user properties for the object with the given list of names.
(Inherited from DatabaseObject.) | |
GetIntegerUserProperties(ListString, DictionaryString, Int32) |
Retrieves all integer user properties for the object with the given list of names.
(Inherited from DatabaseObject.) | |
GetRelatedObjects |
Gets the related objects of the current object.
(Inherited from DrawingObject.) | |
GetRelatedObjects(Type) |
Gets the related objects of the current object that are of certain types.
(Inherited from DrawingObject.) | |
GetStringUserProperties(DictionaryString, String) |
Retrieves all string user properties for the object with the given list of names.
(Inherited from DatabaseObject.) | |
GetStringUserProperties(ListString, DictionaryString, String) |
Retrieves all string user properties for the object with the given list of names.
(Inherited from DatabaseObject.) | |
GetUserProperty(String, Double) |
Gets a double property from the drawing object. The object has to be in a drawing before
the method can be used.
(Inherited from DatabaseObject.) | |
GetUserProperty(String, Int32) |
Gets an integer property from the drawing object. The object has to be in a drawing before
the method can be used.
(Inherited from DatabaseObject.) | |
GetUserProperty(String, String) |
Gets a string property from the drawing object. The object has to be in a drawing before
the method can be used.
(Inherited from DatabaseObject.) | |
GetView |
Gets the view where the drawing object is.
(Inherited from DrawingObject.) | |
Insert |
Calls the system to insert the new object.
(Overrides DatabaseObjectInsert.) | |
IsEqual |
Compares the current object with an object of the same type.
(Overrides DrawingObjectIsEqual(Object).) | |
IsSameDatabaseObject |
Returns true if the current object and the given object are referencing the same database object.
(Inherited from DatabaseObject.) | |
Modify |
Calls the system to update/modify the object.
(Overrides DatabaseObjectModify.) | |
Select |
Calls the system to select and retrieve the object.
(Overrides DatabaseObjectSelect.) | |
SetUserProperty(String, Double) |
Sets a double property for the drawing object. The object has to be in a drawing before
the method can be used.
(Inherited from DatabaseObject.) | |
SetUserProperty(String, Int32) |
Sets an integer property for the drawing object. The object has to be in a drawing before
the method can be used.
(Inherited from DatabaseObject.) | |
SetUserProperty(String, String) |
Sets a string property for the drawing object. The object has to be in a drawing before
the method can be used.
(Inherited from DatabaseObject.) | |
ToString |
Changes the string presentation of the drawing object.
(Inherited from DrawingObject.) |
Examples
using Tekla.Structures.Drawing; using Tekla.Structures.Geometry3d; public class Example { public void Example1() { DrawingHandler MyDrawingHandler = new DrawingHandler(); if(MyDrawingHandler.GetConnectionStatus()) { Cloud MyCloud; PointList PolygonPoints = new PointList(); PolygonPoints.Add(new Point(10,10)); PolygonPoints.Add(new Point(50,10)); PolygonPoints.Add(new Point(50,50)); PolygonPoints.Add(new Point(10,50)); DrawingObjectEnumerator views = MyDrawingHandler.GetActiveDrawing().GetSheet().GetAllViews(); while(views.MoveNext()) { MyCloud = new Cloud(views.Current as ViewBase, PolygonPoints); MyCloud.Insert(); } } } }
See Also