ClosedGraphicObjectClosedGraphicObjectAttributes Class |
The ClosedGraphicObjectAttributes class is the attributes class for the closed graphic object.
Inheritance Hierarchy
SystemObject
Tekla.Structures.DrawingAttributesBase
Tekla.Structures.DrawingGraphicObjectGraphicObjectAttributes
Tekla.Structures.DrawingClosedGraphicObjectClosedGraphicObjectAttributes
Tekla.Structures.DrawingCircleCircleAttributes
Tekla.Structures.DrawingCloudCloudAttributes
Tekla.Structures.DrawingPolygonPolygonAttributes
Tekla.Structures.DrawingRectangleRectangleAttributes
Tekla.Structures.DrawingAttributesBase
Tekla.Structures.DrawingGraphicObjectGraphicObjectAttributes
Tekla.Structures.DrawingClosedGraphicObjectClosedGraphicObjectAttributes
Tekla.Structures.DrawingCircleCircleAttributes
Tekla.Structures.DrawingCloudCloudAttributes
Tekla.Structures.DrawingPolygonPolygonAttributes
Tekla.Structures.DrawingRectangleRectangleAttributes
Namespace: Tekla.Structures.Drawing
Assembly: Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.3
Syntax
The ClosedGraphicObjectClosedGraphicObjectAttributes type exposes the following members.
Properties
Name | Description | |
---|---|---|
BehindModelObjects |
Gets or sets whether the closed graphic object is drawn behind model objects
| |
Hatch |
The hatch attributes of the closed graphic object (the closed graphic object is hatchable).
Methods
Name | Description | |
---|---|---|
See Also