ClashCheckHandler Class |
The ClashCheckHandler class contains clash check methods.
Inheritance Hierarchy
Namespace: Tekla.Structures.Model
Assembly: Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.3
Syntax
The ClashCheckHandler type exposes the following members.
Methods
Name | Description | |
---|---|---|
GetIntersectionBoundingBoxes |
Get a list of bounding boxes (AABB) of the clashing volumes of two objects.
| |
RunClashCheck |
Starts the clash checking. Uses advanced options sa option values.
| |
RunClashCheckWithOptions(Boolean, Boolean, Double, Boolean) |
Starts the clash checking with options.
| |
RunClashCheckWithOptions(Boolean, Boolean, Boolean, Double, Boolean) |
Starts the clash checking with options.
| |
StopClashCheck |
Stops the clash checking.
|
Examples
using Tekla.Structures.Model; public class Example { public void Exmaple1() { Model MyModel = new Model(); ClashCheckHandler ClashCheck = MyModel.GetClashCheckHandler(); ClashCheck.RunClashCheck(); ClashCheck.StopClashCheck(); } }
See Also