ClashCheckData Class |
The ClashCheckData class presents information about the detected clash. It is instantiated inside the onClashDetected method.
The objects store the identifiers and type of the clash to be passed on to event subscribers.
Inheritance Hierarchy
Namespace: Tekla.Structures.Model
Assembly: Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.3
Syntax
The ClashCheckData type exposes the following members.
Constructors
Name | Description | |
---|---|---|
ClashCheckData | Initializes a new instance of the ClashCheckData class |
Properties
Name | Description | |
---|---|---|
Object1 |
Gets the first clashing object.
| |
Object2 |
Gets the second clashing object.
| |
Overlap |
Gets the overlap of the clash. Only applies to clashes of type CLASH_TYPE_CLASH.
| |
Type |
Gets the type of the clash.
|
See Also