ClashCheckDataClashTypeEnum Enumeration |
An enumeration for the different clash types.
Namespace: Tekla.Structures.Model
Assembly: Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.3
Syntax
Members
Member name | Value | Description | |
---|---|---|---|
CLASH_TYPE_INVALID | 0 | The invalid clash type. | |
CLASH_TYPE_ISINSIDE | 1 | One object is inside the other object. | |
CLASH_TYPE_EXACTMATCH | 2 | The exact match clash type. | |
CLASH_TYPE_CLASH | 3 | The unidentified clash type. | |
CLASH_TYPE_MINDISTANCE | 4 | The minimum distance clash type. | |
CLASH_TYPE_FAILEDSOLID | 5 | The failed solid clash type. | |
CLASH_TYPE_CUTTHROUGH | 6 | The cut through clash type. | |
CLASH_TYPE_COMPLEXCLASH | 7 | The complex clash type. | |
CLASH_TYPE_FAILEDTEST | 8 | The failed test clash type. |
See Also