CastUnitDrawing Constructor (Identifier, CastUnitDrawingCastUnitDrawingCreationType, Int32)

Instantiates a new cast unit drawing by id with standard attributes and with a specified sheet number for a given cast unit.

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.3
Syntax
public CastUnitDrawing(
	Identifier castUnitIdentifier,
	CastUnitDrawingCastUnitDrawingCreationType castUnitDrawingCreationType,
	int sheetNumber
)

Parameters

castUnitIdentifier
Type: Tekla.StructuresIdentifier
The identifier of the model object cast unit.
castUnitDrawingCreationType
Type: Tekla.Structures.DrawingCastUnitDrawingCastUnitDrawingCreationType
Specifies the cast unit drawing creation type (by cast unit id or by cast unit position).
sheetNumber
Type: SystemInt32
The sheet number of the drawing.
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next