Building Class |
Class for Building Hierarchy Building
Inheritance Hierarchy
SystemObject
Tekla.Structures.ModelObject
Tekla.Structures.ModelModelObject
Tekla.Structures.ModelInternal.BuildingHierarchyBuildingHierarchyItem
Tekla.Structures.ModelInternal.BuildingHierarchyBuilding
Tekla.Structures.ModelObject
Tekla.Structures.ModelModelObject
Tekla.Structures.ModelInternal.BuildingHierarchyBuildingHierarchyItem
Tekla.Structures.ModelInternal.BuildingHierarchyBuilding
Namespace: Tekla.Structures.ModelInternal.BuildingHierarchy
Assembly: Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.3
Syntax
The Building type exposes the following members.
Constructors
Properties
Name | Description | |
---|---|---|
Bottom |
Gets or sets a building bottom z-level.
| |
Contour |
Gets or sets the contour points for building.
| |
Description |
Gets or sets the Description of the Building.
| |
Height |
Gets or sets a building height.
Methods
Name | Description | |
---|---|---|
Delete |
Deletes the Building Hierarchy object instance with the given identifier from the model database.
GetAllReportProperties |
Retrieves all properties for the model object in one hashtable.
GetAllUserProperties |
Retrieves all properties for the model object in one hashtable.
GetDoubleReportProperties |
Retrieves multiple double report properties for the model object. It is faster
GetIntegerReportProperties |
Retrieves multiple integer report properties for the model object. It is faster
GetPhase |
Retrieves the phase of the model object (the phase number, the phase name,
GetSolid |
Returns the solid of the pour object.
| |
GetStoreys |
Gets all storeys belonging to this site.
Insert |
Inserts this Building Hierarchy object into model database. All the attributes must be set.
(Overrides ModelObjectInsert.) | |
Modify |
Modifies the existing Building Hierarchy object in the model database to match the current one.
(Overrides ModelObjectModify.) | |
Select |
Selects the Building Hierarchy object from model database. The object identifier must be set.
SetLabel |
Sets a label for an object when a new instance is created, this method must be called before Insert.
See Also