BoltBoltAttributes Class |
The BoltAttributes class is the attributes class for the bolt.
Inheritance Hierarchy
Namespace: Tekla.Structures.Drawing
Assembly: Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.3
Syntax
The BoltBoltAttributes type exposes the following members.
Constructors
Name | Description | |
---|---|---|
BoltBoltAttributes |
Creates a new default bolt attributes instance that loads standard attributes.
| |
BoltBoltAttributes(String) |
Creates a new bolt attributes instance that loads the specified attributes.
|
Properties
Name | Description | |
---|---|---|
Color |
The color of the bolt.
| |
CustomPresentation |
Custom presentation GUID to be applied to the bolt
| |
Representation |
The representation type of the bolt.
| |
SymbolContainsAxis |
True if the bolt symbol contains an axis.
| |
SymbolContainsHole |
True if the bolt symbol contains a hole.
|
Methods
Name | Description | |
---|---|---|
IsEqual |
Compares the current object with an object of the same type.
(Overrides AttributesBaseIsEqual(Object).) | |
LoadAttributes |
Loads the attributes from the attribute file.
(Overrides AttributesBaseLoadAttributes(String).) |
See Also