BinaryFilterExpression Constructor (StringFilterExpression, StringOperatorType, StringConstantFilterExpression)

Initializes a new instance of the BinaryFilterExpression class.

Namespace:  Tekla.Structures.Filtering
Assembly:  Tekla.Structures (in Tekla.Structures.dll) Version: 2023.0.3
Syntax
public BinaryFilterExpression(
	StringFilterExpression Left,
	StringOperatorType Oper,
	StringConstantFilterExpression Right
)

Parameters

Left
Type: Tekla.Structures.FilteringStringFilterExpression
The left operand of the filter expression.
Oper
Type: Tekla.Structures.FilteringStringOperatorType
The operator of the filter expression.
Right
Type: Tekla.Structures.FilteringStringConstantFilterExpression
The right operand of the filter expression.
Exceptions
ExceptionCondition
ArgumentNullExceptionThrown when a null filter expression is specified.
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next