![]() | BinaryFilterExpression Constructor (BooleanFilterExpression, BooleanOperatorType, BooleanConstantFilterExpression) |
Initializes a new instance of the BinaryFilterExpression class.
Namespace: Tekla.Structures.Filtering
Assembly: Tekla.Structures (in Tekla.Structures.dll) Version: 2023.0.3
![](/modules/custom/trimble_html_import/icons/SectionExpanded.png)
public BinaryFilterExpression( BooleanFilterExpression Left, BooleanOperatorType Oper, BooleanConstantFilterExpression Right )
Parameters
- Left
- Type: Tekla.Structures.FilteringBooleanFilterExpression
The left operand of the filter expression. - Oper
- Type: Tekla.Structures.FilteringBooleanOperatorType
The operator of the filter expression. - Right
- Type: Tekla.Structures.FilteringBooleanConstantFilterExpression
The right operand of the filter expression.
![](/modules/custom/trimble_html_import/icons/SectionExpanded.png)
Exception | Condition |
---|---|
ArgumentNullException | Thrown when a null filter expression is specified. |
![](/modules/custom/trimble_html_import/icons/SectionExpanded.png)