BentPlateGeometrySolverOperationStatus Enumeration

Define possible statuses for geometry creation/modification commands.

Namespace:  Tekla.Structures.Model
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.3
Syntax
public enum OperationStatus
Members
  Member nameValueDescription
Success0 Status on success creation.
Failure1 General failure mode.
FacePerpendicularToIntersectionLine2 Face perpendicular to intersection line.
PlateIntersectsWithIntersectionLine3 Plate polygon extends beyond intersection line.
ExtensionIntersectsWithPlate4 Extension plate clashes with plates.
FacesTooNearEachOther5 Faces to be connected overlap.
FacesAtAnObtuseAngle6 Faces to be connected are too steep of an angle.
UndefinedCurveDirection7 Can't make inward/outward curve check.
UnsupportedChamfer8 Plates containing unsupported chamfer information.
InvalidRadius9 Cannot connect parts with a cylindrical section having the provided radius.
InvalidFacePoints10 Cannot create geometry from requested face points.
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next