BendSurfaceNode Class |
The BendSurfaceNode class represents a bend surface geometry tree node.
Inheritance Hierarchy
SystemObject
Tekla.Structures.ModelBendSurfaceNode
Tekla.Structures.ModelConicalSurfaceNode
Tekla.Structures.ModelCylindricalSurfaceNode
Tekla.Structures.ModelBendSurfaceNode
Tekla.Structures.ModelConicalSurfaceNode
Tekla.Structures.ModelCylindricalSurfaceNode
Namespace: Tekla.Structures.Model
Assembly: Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.3
Syntax
The BendSurfaceNode type exposes the following members.
Constructors
Name | Description | |
---|---|---|
BendSurfaceNode |
Initializes a new instance of the BendSurfaceNode class.
|
Properties
Name | Description | |
---|---|---|
IsAutomatic |
Gets a value indicating whether this geometry node was automatically generated (returns false if it was originally a user-defined part)
| |
Surface |
Gets the bend surface geometry.
|
Methods
Name | Description | |
---|---|---|
AcceptVisitor |
Entry method for the visitor pattern
| |
Clone |
Creates a new object that is a copy of the current instance.
|
See Also