BaseWeldWeldProcessTypeEnum Enumeration

The weld process type.

Namespace:  Tekla.Structures.Model
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.3
Syntax
public enum WeldProcessTypeEnum
Members
  Member nameValueDescription
WELD_PROCESS_NONE0 No process type.
WELD_PROCESS_SMAW1 The shielded metal arc (SMAW) process type.
WELD_PROCESS_SAW2 The submerged arc (SAW) process type.
WELD_PROCESS_GMAW3 The gas metal arc (GMAW) process type.
WELD_PROCESS_FCAW4 The flux cored arc (FCAW) process type.
WELD_PROCESS_ESW5 The electroslag (ESW) process type.
WELD_PROCESS_EGW6 The electrogas (EGW) process type.
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next