BaseWeld Class |
The BaseWeld abstract class defines a weld between two model objects.
Inheritance Hierarchy
SystemObject
Tekla.Structures.ModelObject
Tekla.Structures.ModelModelObject
Tekla.Structures.ModelBaseWeld
Tekla.Structures.ModelLogicalWeld
Tekla.Structures.ModelPolygonWeld
Tekla.Structures.ModelWeld
Tekla.Structures.ModelObject
Tekla.Structures.ModelModelObject
Tekla.Structures.ModelBaseWeld
Tekla.Structures.ModelLogicalWeld
Tekla.Structures.ModelPolygonWeld
Tekla.Structures.ModelWeld
Namespace: Tekla.Structures.Model
Assembly: Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.3
Syntax
The BaseWeld type exposes the following members.
Properties
Name | Description | |
---|---|---|
AdditionalSizeAbove | Gets or sets the additional size above for combination welds. | |
AdditionalSizeBelow | Gets or sets the additional size below for combination welds. | |
AngleAbove | Gets or sets the angle above. | |
AngleBelow | Gets or sets the angle below. | |
AroundWeld |
Gets or sets a value indicating whether
the weld is an around weld (true) or an edge weld (false).
| |
ConnectAssemblies |
Gets or sets a value indicating whether
to connect a part or an assembly as a secondary part (false)
or as a sub-assembly (true).
| |
ContourAbove | Gets or sets the contour above. | |
ContourBelow | Gets or sets the contour below. | |
EffectiveThroatAbove | Gets or sets the effective throat above. | |
EffectiveThroatBelow | Gets or sets the effective throat below. | |
ElectrodeClassification | Gets or sets the weld electrode classification. | |
ElectrodeCoefficient | Gets or sets the electrode strength coefficient. | |
ElectrodeStrength | Gets or sets the electrode strength. | |
FinishAbove | Gets or sets the finish above. | |
IncrementAmountAbove |
Gets or sets the increment amount above.
| |
IncrementAmountBelow |
Gets or sets the increment amount below.
| |
IntermittentType |
Gets or sets the weld intermittent type.
| |
LengthAbove | Gets or sets the length above. | |
LengthBelow | Gets or sets the length below. | |
MainObject | Gets or sets the main part of the weld. | |
NDTInspection | Gets or sets the NDT inspection level. | |
PitchAbove | Gets or sets the pitch above. | |
PitchBelow | Gets or sets the pitch below. | |
Placement |
Gets or sets the weld placement.
| |
PrefixAboveLine | Gets or sets the size prefix above the line. | |
PrefixBelowLine | Gets or sets the size prefix below the line. | |
Preparation |
Gets or sets the weld preparation.
| |
ProcessType | Gets or sets the process type. | |
ReferenceText | Gets or sets the reference text. | |
RootFaceAbove | Gets or sets the root face above. | |
RootFaceBelow | Gets or sets the root face below. | |
RootOpeningAbove | Gets or sets the root opening above. | |
RootOpeningBelow | Gets or sets the root opening below. | |
SecondaryObject | Gets or sets the secondary part of the weld. | |
ShopWeld |
Gets or sets a value indicating whether
the weld is a shop weld (true) or a site weld (false).
| |
SizeAbove | Gets or sets the size above. | |
SizeBelow | Gets or sets the size below. | |
Standard | Obsolete. Gets or sets the weld detail/standard. | |
StitchWeld | Obsolete.
Gets or sets a value indicating whether
the weld is stitched (true) or not stitched (false).
| |
TypeAbove | Gets or sets the type above. | |
TypeBelow | Gets or sets the type below. | |
WeldNumber | Gets the weld number. | |
WeldNumberPrefix | Gets or sets the weld number prefix. |
Methods
Name | Description | |
---|---|---|
GetAllReportProperties |
Retrieves all properties for the model object in one hashtable.
GetAllUserProperties |
Retrieves all properties for the model object in one hashtable.
GetDoubleReportProperties |
Retrieves multiple double report properties for the model object. It is faster
GetIntegerReportProperties |
Retrieves multiple integer report properties for the model object. It is faster
GetPhase |
Retrieves the phase of the model object (the phase number, the phase name,
GetSolid |
Method for getting the weld solid.
GetWeldGeometries |
Method for getting weld seam geometries.
Every result represents one individual seam geometry in current weld.
SetLabel |
Sets a label for an object when a new instance is created, this method must be called before Insert.
See Also