BaseWeld Class |
The BaseWeld abstract class defines a weld between two model objects.
Inheritance Hierarchy
SystemObject
Tekla.Structures.ModelObject
Tekla.Structures.ModelModelObject
Tekla.Structures.ModelBaseWeld
Tekla.Structures.ModelLogicalWeld
Tekla.Structures.ModelPolygonWeld
Tekla.Structures.ModelWeld
Tekla.Structures.ModelObject
Tekla.Structures.ModelModelObject
Tekla.Structures.ModelBaseWeld
Tekla.Structures.ModelLogicalWeld
Tekla.Structures.ModelPolygonWeld
Tekla.Structures.ModelWeld
Namespace: Tekla.Structures.Model
Assembly: Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.3
Syntax
The BaseWeld type exposes the following members.
Properties
Name | Description | |
---|---|---|
AdditionalSizeAbove | Gets or sets the additional size above for combination welds. | |
AdditionalSizeBelow | Gets or sets the additional size below for combination welds. | |
AngleAbove | Gets or sets the angle above. | |
AngleBelow | Gets or sets the angle below. | |
AroundWeld |
Gets or sets a value indicating whether
the weld is an around weld (true) or an edge weld (false).
| |
ConnectAssemblies |
Gets or sets a value indicating whether
to connect a part or an assembly as a secondary part (false)
or as a sub-assembly (true).
| |
ContourAbove | Gets or sets the contour above. | |
ContourBelow | Gets or sets the contour below. | |
EffectiveThroatAbove | Gets or sets the effective throat above. | |
EffectiveThroatBelow | Gets or sets the effective throat below. | |
ElectrodeClassification | Gets or sets the weld electrode classification. | |
ElectrodeCoefficient | Gets or sets the electrode strength coefficient. | |
ElectrodeStrength | Gets or sets the electrode strength. | |
FinishAbove | Gets or sets the finish above. | |
FinishBelow | Gets or sets the finish below. | |
Identifier |
The identifier of the object.
(Inherited from Object.) | |
IncrementAmountAbove |
Gets or sets the increment amount above.
| |
IncrementAmountBelow |
Gets or sets the increment amount below.
| |
IntermittentType |
Gets or sets the weld intermittent type.
| |
IsUpToDate | Gets if the object does not have a modification which is not shared. (Inherited from ModelObject.) | |
LengthAbove | Gets or sets the length above. | |
LengthBelow | Gets or sets the length below. | |
MainObject | Gets or sets the main part of the weld. | |
ModificationTime | Gets latest time of the object was modified or created. (Inherited from ModelObject.) | |
NDTInspection | Gets or sets the NDT inspection level. | |
PitchAbove | Gets or sets the pitch above. | |
PitchBelow | Gets or sets the pitch below. | |
Placement |
Gets or sets the weld placement.
| |
PrefixAboveLine | Gets or sets the size prefix above the line. | |
PrefixBelowLine | Gets or sets the size prefix below the line. | |
Preparation |
Gets or sets the weld preparation.
| |
ProcessType | Gets or sets the process type. | |
ReferenceText | Gets or sets the reference text. | |
RootFaceAbove | Gets or sets the root face above. | |
RootFaceBelow | Gets or sets the root face below. | |
RootOpeningAbove | Gets or sets the root opening above. | |
RootOpeningBelow | Gets or sets the root opening below. | |
SecondaryObject | Gets or sets the secondary part of the weld. | |
ShopWeld |
Gets or sets a value indicating whether
the weld is a shop weld (true) or a site weld (false).
| |
SizeAbove | Gets or sets the size above. | |
SizeBelow | Gets or sets the size below. | |
Standard | Obsolete. Gets or sets the weld detail/standard. | |
StitchWeld | Obsolete.
Gets or sets a value indicating whether
the weld is stitched (true) or not stitched (false).
| |
TypeAbove | Gets or sets the type above. | |
TypeBelow | Gets or sets the type below. | |
WeldNumber | Gets the weld number. | |
WeldNumberPrefix | Gets or sets the weld number prefix. |
Methods
Name | Description | |
---|---|---|
CompareTo |
Compares Identifiers of model objects.
(Inherited from ModelObject.) | |
Delete |
Deletes the instance from the model database.
(Inherited from ModelObject.) | |
Equals |
Check if Identifiers of model objects are same.
(Inherited from ModelObject.) | |
GetAllReportProperties |
Retrieves all properties for the model object in one hashtable.
Type for the returned value must be checked using type casting.
(Inherited from ModelObject.) | |
GetAllUserProperties |
Retrieves all properties for the model object in one hashtable.
Type for the returned value must be checked using type casting.
(Inherited from ModelObject.) | |
GetChildren |
Returns an enumerator of all the children model objects.
(Inherited from ModelObject.) | |
GetCoordinateSystem |
Returns the coordinate system for the given model object.
(Inherited from ModelObject.) | |
GetDoubleReportProperties |
Retrieves multiple double report properties for the model object. It is faster
to fetch multiple properties at once.
(Inherited from ModelObject.) | |
GetDoubleUserProperties |
Retrieves all double properties for the model object.
(Inherited from ModelObject.) | |
GetDynamicStringProperty |
Gets a dynamic string property from the model object.
(Inherited from ModelObject.) | |
GetFatherComponent |
Returns the father component of the model object.
(Inherited from ModelObject.) | |
GetHierarchicObjects |
Returns an enumerator of all the connected hierarchic objects.
(Inherited from ModelObject.) | |
GetIntegerReportProperties |
Retrieves multiple integer report properties for the model object. It is faster
to fetch multiple properties at once.
(Inherited from ModelObject.) | |
GetIntegerUserProperties |
Retrieves all integer properties for the model object.
(Inherited from ModelObject.) | |
GetPhase |
Retrieves the phase of the model object (the phase number, the phase name,
the phase comment and whether the phase is the current one or not).
(Inherited from ModelObject.) | |
GetReportProperty(String, Double) |
Retrieves a double property of the report for the model object.
(Inherited from ModelObject.) | |
GetReportProperty(String, Int32) |
Retrieves an integer property of the report for the model object.
(Inherited from ModelObject.) | |
GetReportProperty(String, String) |
Retrieves a string property of the report for the model object.
(Inherited from ModelObject.) | |
GetSolid |
Method for getting the weld solid.
| |
GetStringReportProperties |
Retrieves multiple string report properties for the model object. It is faster
to fetch multiple properties at once.
(Inherited from ModelObject.) | |
GetStringUserProperties |
Retrieves all string properties for the model object.
(Inherited from ModelObject.) | |
GetUserProperty(String, Double) |
Retrieves a double property for the model object.
(Inherited from ModelObject.) | |
GetUserProperty(String, Int32) |
Retrieves an integer property for the model object.
(Inherited from ModelObject.) | |
GetUserProperty(String, String) |
Retrieves a string property for the model object.
(Inherited from ModelObject.) | |
GetWeldGeometries |
Method for getting weld seam geometries.
Every result represents one individual seam geometry in current weld.
| |
Insert |
Inserts the model object instance into the model database.
(Inherited from ModelObject.) | |
Modify |
Modifies the model instance in the model database.
(Inherited from ModelObject.) | |
Select |
Selects the model object instance from the model database.
(Inherited from ModelObject.) | |
SetDynamicStringProperty |
Sets a dynamic string property for the model object.
(Inherited from ModelObject.) | |
SetLabel |
Sets a label for an object when a new instance is created, this method must be called before Insert.
The label is used in plug-ins for identifying the changed object in modification.
(Inherited from ModelObject.) | |
SetPhase |
Sets the phase of the model object.
(Inherited from ModelObject.) | |
SetUserProperties |
Sets multiple properties for the model object.
(Inherited from ModelObject.) | |
SetUserProperty(String, Double) |
Sets a double property for the model object.
(Inherited from ModelObject.) | |
SetUserProperty(String, Int32) |
Sets an integer property for the model object.
(Inherited from ModelObject.) | |
SetUserProperty(String, String) |
Sets a string property for the model object.
(Inherited from ModelObject.) |
See Also