BaseLinePlacing Class

The BaseLinePlacing class defines a placing where the object is placed using a line as a reference. This will thus define the object's X-axis along that line.
Inheritance Hierarchy

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.3
Syntax
[SerializableAttribute]
public class BaseLinePlacing : PlacingBase

The BaseLinePlacing type exposes the following members.

Constructors
  NameDescription
Public methodBaseLinePlacing
Creates a new base line placing instance. The given two points define the line to be used for the placing.
Top
Properties
  NameDescription
Public propertyEndPoint
Sets the end point of the line that the object is using for the placement.
Public propertyStartPoint
Sets the start point of the line that the object is using for the placement.
Top
Methods
  NameDescription
Public methodIsEqual
Compares the current object with an object of the same type.
(Overrides PlacingBaseIsEqual(Object).)
Top
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next